RSync + SSH tunneling through firewall

Stefaan Lhermitte stefaan.lhermitte at
Tue Sep 7 21:49:12 GMT 2004

Nope, I cannot telnet port 873. I tried "telnet C-computer" and "telnet 
C-computer 873" but command give the error:
Connection refused.

On the other hand, the SSH command from B-computer to C-computer works 
does give connection without any problems.

Thanx in advance,

Andrzej Filip wrote:

> Stefaan Lhermitte wrote:
>> I'm trying to rsync my labtop pc (let's assume A-computer) with my 
>> desktop pc (let's assume C-computer) through our firewall.
>> In between there is one computer (let's assume B-computer) that has 
>> an open port, so I theoretically could connect via a tunnel.
>> I checked the SSH- website and internet and so on but did not find an 
>> answer that works.
>> I tried the solution I found on the net:
>> When I run ssh -v -L 873:C-computer:873 myname at B-computer and get 
>> connected to B-computer without any problems.
>> When I subsequently run in a new window:
>> rsync -v /cygdrive/d/folder/ cygdrive/folder
>> I get the following error:  Connection reset by peer.
>> In the tunneling window teh following error appears: 
>> administrativetly prohibited: open failed
> Can you telnet port 873 on C from B ?
> [ Is rsync daemon listening on C ? ]
>> I'm kind of new in the SSH-RSYNC world and don't know how to solve 
>> the problem.
>> I assume it is an SSH problem since the problem persist when I run:  
>> ssh myname at localhost -p 873.


Stefaan Lhermitte
Research Associate
Lab of Geomatics and Forest Engineering K.U. Leuven
Vital Decosterstraat 102. B-3000 Leuven Belgium
Tel:+32-(0)16-329750 Fax: +32-(0)16-329760 Cell: +32-(0)494-350842
stefaan.lhermitte at
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list