RSync + SSH tunneling through firewall

Stefaan Lhermitte stefaan.lhermitte at
Tue Sep 7 21:16:14 GMT 2004

Dear RSYNCians,

I'm trying to rsync my labtop pc (let's assume A-computer) with my 
desktop pc (let's assume C-computer) through our firewall.
In between there is one computer (let's assume B-computer) that has an 
open port, so I theoretically could connect via a tunnel.
I checked the SSH- website and internet and so on but did not find an 
answer that works.

I tried the solution I found on the net:
When I run ssh -v -L 873:C-computer:873 myname at B-computer and get 
connected to B-computer without any problems.

When I subsequently run in a new window:
rsync -v /cygdrive/d/folder/ cygdrive/folder
I get the following error:  Connection reset by peer.
In the tunneling window teh following error appears: administrativetly 
prohibited: open failed

I'm kind of new in the SSH-RSYNC world and don't know how to solve the 
I assume it is an SSH problem since the problem persist when I run:  ssh 
myname at localhost -p 873.

Thanx for your help in advance,

More information about the rsync mailing list