Essyug essyug at free.fr
Thu Sep 2 14:05:08 GMT 2004


I'm setting up a Linux backup server for Windows Workstations, using
rsync-2.6.3pre1+acl on the server and cygwin rsync-2.6.2-2 on the
Workstations. At this point, I don't care about perserving the acls ; I
only want to preserve the ownership of the files. My server is running
in daemon mode as root, and winbindd (from samba 3.0.6) is running 
correctly : I can get all the users entries from my W2k PDC with 
"gentent passwd", their uid beeing mapped to the 10000-20000 range. Here 
is my /etc/rsyncd.conf file :

path = /backuptest
uid = root
gid = root
read only = false

My test directory on W2k and all its content are owned by 
DOMAIN\testuser, which is a domain administrator.

When I run the following command under cygwin:

rsync -avP testdir $BACKUPserver::backuptest

... the directory is owned by 544:root on the Linux server. Samba shows 
the owner as S-12345-etc.

I've tried --numeric-ids with exactly the same result. This is annoying 
since a would like to use quota on the backup partition.

Is there any way to work aroubnd this problem ?

More information about the rsync mailing list