Compile error on cygwin

Dan Bolser dmb at
Thu Sep 2 09:10:40 GMT 2004


I am am new to cygwin, so if this email lacks any glaring detail,
please let me know how I can send it along.

Rsync is the first app I have tried to install on cygwin, I have version
2.5.5 already installed, but I am trying to upgrade to remove the 'rsync
hangs with cygwin' problem.

I am trying to install verison 2.6.2 from rsync-2.6.2.tar.gz. 

Configure runs fine, but make gives me the following output...

$ make
gcc -I. -I. -g -O2 -DHAVE_CONFIG_H -Wall -W  -c rsync.c -o rsync.o
In file included from rsync.c:23:
rsync.h:276:17: operator '==' has no left operand
rsync.h:278:20: operator '==' has no left operand
rsync.h:280:21: operator '==' has no left operand
rsync.h:303:20: operator '==' has no left operand
rsync.h:305:19: operator '==' has no left operand
rsync.h:315:18: operator '==' has no left operand
rsync.h:317:19: operator '==' has no left operand
make: *** [rsync.o] Error 1

I tried to build version 2.4.0 as per the exelent instructions provided
by Paul Thompson at

And it does compile, creating an rsync.exe

However, this exe is mostly unresponsive, and when it does do something it
does a core dump. i.e. 

$ ./rsync --verions
rsync: unknown option -- verions
Segmentation fault (core dumped)

$ ./rsync --version

$ ./rsync --help
Segmentation fault (core dumped)

The above error (about ==) does not appear in google, so any help you
could offer a novice would be greatly appreciated.

$ uname -a
CYGWIN_NT-5.1 GENUS 1.3.15(0.63/3/2) 2002-11-06 22:41 i686 unknown


More information about the rsync mailing list