rsync 2.6.3 hang (was rsync 2.6.2 crash)

Paul Arch paul at
Thu Oct 7 07:30:20 GMT 2004

 > "jim" writes:
 > > Thanks for the additional info.
 > >
 > > I actually have tried the --no-blocking-io option, but the sync
 > > still hung.
 > >
 > > Since no one on Unix-like platforms are reporting an issue, do you
 > > think it may be something in the Cygwin compatibility layer?
 > Yes, I think so.  When I tried to debug this some time ago with rsync
 > over ssh using cygwin I found that data that was flushed by one end's
 > rsync never arrived at the other end: the other end was still blocked
 > on select. I presume that somewhere between rsync/ssh/cygwin, and
 > cygwin/ssh/rsync on the other end, some buffer was not getting flushed
 > properly. I don't know anything about cygwin internals, so I didn't
 > look at this further.
 If its worth it, I too was getting hangs with rsync and cygwin (latest
 release of both).  I now actually run rsync over stunnel under windows :
 This seems to work quite well, with no more hangs I have seen :)
 Hope this can be of some help.
  Paul Arch

More information about the rsync mailing list