rsync 2.6.3 hang (was rsync 2.6.2 crash)

Craig Barratt cbarratt at
Wed Oct 6 02:08:01 GMT 2004

"jim" writes:

> Thanks for the additional info.
> I actually have tried the --no-blocking-io option, but the sync
> still hung.
> Since no one on Unix-like platforms are reporting an issue, do you
> think it may be something in the Cygwin compatibility layer?

Yes, I think so.  When I tried to debug this some time ago with rsync
over ssh using cygwin I found that data that was flushed by one end's
rsync never arrived at the other end: the other end was still blocked
on select. I presume that somewhere between rsync/ssh/cygwin, and
cygwin/ssh/rsync on the other end, some buffer was not getting flushed
properly. I don't know anything about cygwin internals, so I didn't
look at this further.

> Interestingly (to me anyway,) is that I have encountered the
> problem with syncing across the network using ssh, and syncing
> locally, but not over the network rsync to rsync. Maybe it's
> just a matter of time....

I've never seen this with rsync/cygwin <--> rsync/cygwin, only with
ssh.  I haven't tested local rsync on cygwin that much.


More information about the rsync mailing list