[Bug 1959] writefd_unbuffered failed to write 4092 bytes phase send_file_entry broken pipe

samba-bugs at samba.org samba-bugs at samba.org
Fri Nov 19 12:50:18 GMT 2004


------- Additional Comments From jlowery at zertis.net  2004-11-19 05:50 -------
I am experiencing similar problems on debian woody (linux 2.4.26 and after
upgrading to linux 2.4.28). This problem started suddenly after over 100 days of
clean daily operation.

Rsyncing any two folders of larger size causes rsync to hang and the process
waits until it is manually killed. I have reproduced this with rsyncing a remote
directory to a local directory and rsyncing two local directories. I have tried
rsyncing two local directories on different hard drives with the same result. To
test if it was some disk IO error, I've ran md5deep on the directory to be
rsynced and it finishes properly. This error occurs with the debian woody
version of rsync (2.5.5) and also with the latest rsync downloaded from source

Rsync always hangs during the first stage when calculating what files to sync.
I have attached a sample shell session and strace output.

Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list