ssh+rsync to Windows

Scott LeFevre slefevre at
Sun May 2 18:53:48 GMT 2004

After doing a lot of reading and search this lists' archieve I'm stuck!

I'm trying to run a seemingly simply rsync from my RH9 box to an XP 
desktop.  I have rsync 2.5.7 on the RH9 and rsync 2.6.0 on XP with 
Cygwin.  ssh is working using key authentication.  Anonymous rsync to XP 
works from RH9.  I'm trying to get the rsync to run over ssh.  Here's 
what I've tried.

First attempt ----------------
My /etc/rsyncd.conf file on XP looks like:
use chroot = false
strict modes = false
log file = /var/log/rsyncd.log
transfer logging = true
pid file = /var/run/

        path /cygdrive/e/util
        comment = various utilities

The man page on rsync states:
       An  rsync  server  is  configured  using a config file.  Please 
see the
       rsyncd.conf(5) man page for more information.  By default the  
       ration  file is called /etc/rsyncd.conf, unless rsync is running 
over a
       remote shell program and is not running as  root;  in  that  
case,  the
       default name is rsyncd.conf in the current directory on the 
remote com-
       puter (typically $HOME).

So I copy /etc/rsyncd.conf to /home/Administrator on XP

 >From the rh9 box I ran:
[root at rh9 root]# rsync -n -avvv --rsh ssh Administrator at xp:util/ xxx/
opening connection using ssh -l Administrator xp rsync --server --sender 
-vvvnlogDtpr . util/
receiving file list ...
server_sender starting pid=2864
link_stat "/home/Administrator/util/." failed: No such file or directory
received 0 names
recv_file_list done
client: nothing to do: perhaps you need to specify some filenames or the 
--recursive option?
rsync error: some files could not be transferred (code 23) at main.c(636)
_exit_cleanup(code=0, file=main.c, line=636): about to call exit(23)

It appears that rsync is not reading the $HOME/rsyncd.conf.  I've 
checked the permissions of $HOME/rsyncd.conf and the Administrator owns 
the file w/  read & write access.  Does any have any experience or 
explanation for this??

Second attempt---------
I then tried to setup a root user in the following manner.  In 
/etc/passwd I duplicated the Administrator line and changed the name to 
root and the UID:GID to 0:0 like this:

Then in /etc/group I duplicaetd the Administrators line and changed the 
name to root and the GID to 0 like this:

I could then run ssh root at xp and login without any problems.

I then ran :
[root at rh9 root]# rsync -n -avvv --rsh ssh root at xp:util/ xxx/
opening connection using ssh -l root xp rsync --server --sender 
-vvvnlogDtpr . util/
setgid: Invalid argument
rsync: connection unexpectedly closed (0 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(165)
_exit_cleanup(code=12, file=io.c, line=165): about to call exit(12)

So at this point I'm stuck! 
If anyone has any ideas, experience, or insights with either one of 
these scenarios, I would appreciate the help.

Scott LeFevre

More information about the rsync mailing list