orphan dirs and files with --delete

Eric Whiting ewhiting at amis.com
Tue Mar 23 03:24:27 GMT 2004

I still get the same error with --force --delete.

There needs to be a chmod on dir before the files and dir can be deleted.


Tim Conway wrote:
>           --force                 force deletion of directories even if
> not empty
> SunOS 5.8           Last change: 26 Jan 2003                    7
> User Commands                                            rsync(1)
> That should do it.
> Tim Conway
> Unix System Administration
> Contractor - IBM Global Services
> desk:3032734776
> conway at us.ibm.com
> rsync (2.5.[67]) --delete fails on dirs with the w bit cleared. (example
> below)
> Rsync will sync a dir with w bit clear, but will not remove it with
> --delete.
> This is not a big problem, but it will create situations where there are
> 'orphaned' files.
> Has anyone else had this problem?
> It looks like a change would be needed in robust_unlink (util.c). This
> function
> would have to do a chmod on dirs that are locked down before it does the
> unlink.
> (syncing as user root doesn't have this problem)
> --
> To unsubscribe or change options: http://lists.samba.org/mailman/listinfo/rsync
> Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html

More information about the rsync mailing list