possible writefd_unbuffered error; what am I screwing up this time

Wallace Matthews wmatthews at sepaton.com
Fri Jun 18 17:44:29 GMT 2004

I am trying to execute rsync manually at a "remote" server to test out --read-batch execution.

I created the batch files on another server and then rcp'ed them to the "remote" server. I had some issues of not having the
correct working directory on the remote system when I did an rsh "remote" rsync --read-batch ...... so I opened a telnet session
on the remote system and did the following command

rsync --backup --read-batch=brf --block-size=1000 /test/miki_briefcase

result was rsync:writefd_unbuffered failed to write 64 bytes: phase "unknown": Broken Pipe

brf.rsync_argvs contains the following
rsync -acvv --rsh=rsh --backup --stats --read-batch=brf --block-size=1000 ${1:-/test/miki_briefcase}

I have tried the command with and without -acvv --rsh --stats and it always fails with the same message

I would appreciate any pointers as to what I am screwing up. I have chmod'ed all the brf* files to 0777 and the execution account
owns all of them.

I also tried to do the rsh "remote" alternative from the "local" server and it has a problem finding brf.rsync_flist. I strongly suspect this
is because the rsh's rlogin is setting the working directory to /home/wally. 


More information about the rsync mailing list