Problem in using rsync

Anh Truong transfert.curateur at
Thu Jun 17 14:11:19 GMT 2004


I use rsync to perform backup on disk on a SunFire 880 with Solaris 8. For 
performance issues, we launch simultaneously 5 rsyncs on 5 different fliesystems 
and about 150-200 "cp -p" commands on as many database files. We have been 
using the same scripts for about 2 months, without problems. The backup is 
performed on the same server (from filesystem to filesystem on the same server).

Last weekend, we replaced the 4X750MHz by 8X1200MHz CPU's and upgraded 
from 8 to 16 MB of RAM. Since then, we had 2 errors out of 3 backup runs. The error 
is always on the same filesystem, which is not the largest one but the one that has 
the more files and directories (400 000 files as opposed to 600 for others). The 
error message we have is:

io timeout after 600 seconds - exiting
rsync error: timeout in data send/receive (code 30) at io.c(143)
rsync: writefd_unbuffered failed to write 69 bytes: phase "unknown": Broken pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)
The command used is:

OPTS="--delete --timeout=600 --exclude dbf/ --rsh=rsh"


In the documentation, it is said that this kind of error might be related to either:

Disk full = This is not the case
Remote rsync is not found = It is on the same server, so it is found
remote-shell setup isn't working right or isn't "clean" = I tried the suggested testing 
and there is no problem. Moreover, it worked before...

I saw also that the rsync process might have been starving for CPU or memory, In 
our case I do not think it might be the case.
Can you help me on this???

Thanks in advance

More information about the rsync mailing list