backup complete server

Scott Miller srmiller at
Mon Jul 19 17:39:45 GMT 2004

I'm new to rsync, and am setting up two servers (Fedora Core 1) - one bing
the "primary" and one the "backup".


On the primary server, I have the following rsyncd.conf file:

pid file = /var/run/
path = /
use chroot = false
read only = true
list = false
uid = 0
gid = 0
hosts allow =

>From the backup server, I try to run the following commands, but get errors:

rsync -v
rsync failed to connect to  connection refused
rsync error:  error in socket IO (code 10) at clientserver.c(83)

I then tried (from the backup server) the following:

rsync -v
connecting to address Connection refused
trying krb4.rsh...
connecting to address Connection refused
trying normal rsh (/usr/bin/rsh) Connection refused
rsync: connection unexpectedly closed (o bytes read so far)
rsync error: error in rsync protocol data stream (code 21) at IO.c (165)

>From everything i've read, it should be correct, but still not working.  Can
anyone please point out what I could be doing wrong?

My goal is to have the backup server take a complete backup of the /etc and
/home and /var directories every night, but want to get at least some files
moving before I start specifying what "to" and "not to" move.


Outgoing mail is certified Virus Free.
Checked by AVG Anti-Virus (
Version: 7.0.253 / Virus Database: 263.4.6 - Release Date: 7/19/2004

More information about the rsync mailing list