mkstemp failed: (code 23) main(633)

lothar esser lesser at
Sat Jul 17 16:13:12 GMT 2004


  I am a new user and tried at least some of the recommended ways to find
an answer to my question (search the net, ask IT professionals). But
when everything fails nothing beats newsgroups...

Here is my problem. I compiled rsync 2.6.2 on a Tru64 v5.1b system. I am
trying to use rsync to backup data to a NFS mounted disk outside our
immediate local network. Needless to say that rsync works fine for all
local disks whether nfs mounted or local to the cpu.
However when I try to use rsync to copy files on the remote system (yet
NFS mounted so I don't have to use remote login )

rsync -rav Adir c

rsync copies the directory tree under Adir just fine but not a single
regular (text, binary) file.

mkstemp "/usr/rsync/c/TestA/.TestA.1.hTdMYs" failed: Operation not
supported on socket

rsync error: some files could not be transferred (code 23) at main.c(633)

In Adir is a directory TestA and below a text file called TestA.1

I don't understand why the name was mangled to .TestA.1.hTdMYs which is
different every time i call rsync except the part .TestA.1.
Obviously, this file is not copied. My understanding  from reading
messages on the web, is that mkstemp tries to set the time stamp and/or
permissions but fails for certain systems like FAT32 but the general
consensus was "no big deal". I would also not care too much about that but
here it does not even copy the file at all. What is the difference between
a regular file and a directory in this context ? Again the complete tree
of dirs is copied but not a single file else.
BTW I tried the same thing on IRIX 6.5.23 with the latest rsync that SGI
provides and got the same problem.

Can anyone point me to a solution ? (Sorry for the length...)



Dr. Lothar Esser
Tel. 301-435-6316
email lesser at

More information about the rsync mailing list