Rsync dies and gets slows down

Prasad Narasimha prasad at
Fri Jul 16 11:40:07 GMT 2004


I am trying to sync a staff directory NFS mounted on a Linux server which is
around 60 GB total size and syncing to another remote Linux server. Rsync
version is 2.6.2 on both machines. When I ran rsync for the first time, it
appeared to build the entire list within 5 minutes and after syncing the
diffs for next 10 minutes, got an error as follows:

## rsync -avz -e rsh /mnt/ estor:/BigDir2/maxwell/staff/
wrote 35872427 bytes  read 124859 bytes  32949.46 bytes/sec
total size is 111951418761  speedup is 3110.00
rsync error: some files could not be transferred (code 23) at main.c(633)

What this error means?

Now I tried to sync only one folder under /mnt which should be a small
fraction of entire /mnt folder synced previously, it appears to take some 15
minutes to build file list for the single folder. Is this due to "memory
leak" by the application or the system? This is commonly I have observed on
my personal PC running Windows 2000 workstation where if I run some cpu /
memory intensive jobs for half an hour period, the entire system slows down
for any further jobs until I reboot the system. 


More information about the rsync mailing list