HP-UX 11i and largefiles on rsync 2.6.2

Don Malloy nixuser23 at hotmail.com
Wed Jul 14 20:46:41 GMT 2004


I'm running HP-UX 11i on an rp74xx. It's 64-bit.

C compiler is as follows:

B3901BA B.11.11.03 HP C/ANSI C Developer's Bundle for HP-UX 11.i (S800)
B3913DB C.03.30.02 HP aC++ Compiler (S800)

         LINT B.11.11.02 CXREF B.11.11.02
        HP92453-01 B.11.11.02 HP C Compiler
         $   Sep  8 2000 23:13:51 $

I have successfully compiled rsync 2.6.2 and it runs properly.

>From various partial threads, I have tried --enable-largefile (which seems 
not to be referenced in 2.6.2)

>From the list as well, the following output from the configure suggests that 
largefiles are supported:

checking for broken largefile support... no
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no

Both source and destination filesystems are set to handle largefiles and 
both scp and rcp have worked to transfer the files being tested. I have also 
tried rsync'ing between two local filesystems (both with largefiles 
supported) with the same result.

The rsync transfers always fail at the 2GB mark.

The rsync output is as follows:

server1 # /tmp/rsync --rsync-path=/tmp/rsync --stats file1.db 
rsync: writefd_unbuffered failed to write 32768 bytes: phase "unknown": 
Broken pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)

There seem to be some similar questions in the list archives, however the 
solutions don't seem to be there, or are partial bits of what I have tried 

If anyone has any guidance, please, I need to get this going asap.


MSN Premium includes powerful parental controls and get 2 months FREE*   

More information about the rsync mailing list