rsync and socket files on HP-UX

ulrich.tehrani at ulrich.tehrani at
Fri Jul 2 08:52:43 GMT 2004


i tried to pull files from a linux server to a hp-ux server via

rsync -avz -e /usr/bin/ssh  root at bsl61u:/tmp /danzas1/dump/testle.

It failed for the socket fails. 

receiving file list ...
server_sender starting pid=20793
[sender] make_file(daemon,*,2)
[sender] expand file_list to 131072 bytes, did move
received 1 names
recv_file_list done
get_local_name count=1 /danzas1/dump/testle
recv_files(1) starting
generator starting pid=20788 count=1
send_file_list done
delta transmission enabled
send_files starting
mknod "/danzas1/dump/testle/daemon" failed: Invalid argument
generate_files phase=1
recv_files phase=1
generate_files phase=2
generate_files finished
send_files phase=1
send files finished
total: matches=0  tag_hits=0  false_alarms=0 data=0
recv_files finished

After that i tried to copy files locally on the hp-ux system but same error.
Problem seems to be the mknod command on hp-ux that isn't able to build
socket files.

On Linux this problem doesn't occur

it think i don't need the socket files for recovery a system (am i right
?) but i want to get rid of the errors ?

Has anybody an idea ?

I am running rsync 2.6.2 on hp-ux 11.00. I also tried older versions but
same error.

Thanks in advance 


More information about the rsync mailing list