rsync error using ssh : @ERROR: access denied to from unknown ( {Scanned By MailScanner}

AI Connex rsync_maillist at
Wed Jan 28 00:31:53 GMT 2004

I use rsync to mirror several servers.

I run RH7.3

My rsyncd.conf file is:

motd file = /etc/rsync.d/rsync.motd
log file = /var/log/rsyncd.log
pid file = /var/run/
lock file = /var/run/rsync.lock
hosts allow =
hosts deny =
use chroot = yes
max connections = 3
#syslog facility =

   path = /var/www/website
   comment = Connex Live WWW Server
   uid = nobody
   gid = nobody
   read only = no
   list = yes
   auth users = someone,root
   secrets file = /etc/rsync.d/rsync.secrets

I use the --rsh=ssh option to use a ssh protocol

A typical script contains:

### Setting user

echo Synchronizing Website

rsync --rsh=ssh \
 --password-file=/root/.rsyncpwd  \
 --compress --recursive --times --perms --links --owner --group \
 --include "web_order*" --include "web_user.*" --include
"web_user_c*" --include "web_user_h*" \
 --include "web_user_l*" --include "web_org*" --include "web_in*" --include
"web_quote*" \
 --include "quick_connect.*" \
 --exclude "*" \ /var/www/website

Everything worked perfectly.

I am now getting the error
@ERROR: access denied to from unknown (

If I changed the script so I do not use a ssh shell, everything works fine.

I have hunted the web for a solution, but no joy.

Please advise how I correct the problem.

More information about the rsync mailing list