Cygwin hang-problem resolved

cbarratt at cbarratt at
Thu Jan 22 18:47:57 GMT 2004

"Mark Weaver" writes:

> Not for me!  I'm using cygwin-1.5.6-1, with rsync 2.5.7-2 (as reported by
> cygcheck -s).  I've also tried with rsync-1.4.0 (as someone reported that
> worked), and rsync-2.6.0, both built from source.  I get a 100% reliable
> hang after the first 0-128k of the first file.  Command looks like:
> rsync -e ssh -ar sparky:"/cygdrive/c/www\ sites/" /cygdrive/c/wwwsites
> The directory tree comes across, then the first file stops the transfer.
> Killing the client end always leaves the process running on the server.
> ssh/sftp both seem fine.  All disks involved are local (not network mounted
> shares).

This is a different problem.  I've never found rsync + ssh + cygwin
to be reliable, and I don't know why.  Rsyncd + cygwin has been very
reliable for me except for the well-known receiver-side hang.

The well-known hang referred to in this thread happens at the very end
of the transfer at the receiving end when the parent process fails to
kill the child.  By all reports, cygwin-1.5.6-1 solves this problem.

BTW, cygwin-1.5.6-1 has some significant new bugs and will be shortly
updated to cygwin-1.5.7-1.


More information about the rsync mailing list