Performance problem

Andrew Boyce-Lewis aboyce at
Mon Jan 12 23:22:04 GMT 2004

Hi, I am running rsync version 2.5.7 (stock distro on redhat linux, ES
and 9) to rsync a directory with ~300k files in it from a machine on a
10Mbit internet tap to a machine with a 100Mbit internet tap. The
problem is that I am only getting about 500Kbps during the transfer. I
have tested link speed by scping a file between the two systems,
performance was approximately 7.5Mbit/sec.  Ping time between the two
locations is about 2.5 ms (only 20 miles apart)

This is obviously a problem. I have also tried rsyncing just a few files
(say 400) to rule out problems related to huge file lists, however I had
the same problem. 

Is this a known problem? Am I missing something really obvious?

I have tried testing drive performance in each machine and have found it
to be acceptable. 

The line that I am using to do the rsync is the following:

rsync -avvu --exclude-from=/root/sync_list.exclude --delete -e ssh
--stats /data/ dest:/data/

Any idea?


Andrew E. Boyce-Lewis
Phone: 	800 493-5045 x 210
Fax:	(814) 867-8248
Cell:   (814) 360-6868
GPG key available at

Please AVOID sending me WORD, EXCEL or POWERPOINT attachments.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url :

More information about the rsync mailing list