-a and Preserving permissions

Mauricio Tavares raub at afn.org
Tue Feb 17 15:32:13 GMT 2004


	Ok, if I want to preserve the owner/group setting in the stuff I
am rsyncing around, shouldn't I have the option -a when I call it from the
source machine (still kushana in my case)?  Currently, I am calling rsync
as

raub at kushana-18>rsync -avz --password-file=/export/home/raub/nogo \
	/export/home/raub/sync-me \
	raub at katri::tmp

I have tried running the above as root, changing the password file's (in
kushana) ownership appropriately, but had no luck.  Then I tried to set
the user as root, adding it to the /etc/rsync.secret file in the server
(katri) machine (and quickly removed that), set the user as root, and
tried again:

# rsync -avz --password-file=/export/home/raub/nogo \
        /export/home/raub/sync-me \
        root at katri::tmp

And had the very same result:

katri# !ls
ls -l /tmp/
total 1
-rwxr-xr-x  1 nobody  wheel  552 Feb 17 10:28 sync-me*
katri# 

What could I be doing wrong here?



More information about the rsync mailing list