SSH Tunnel Problem

d c casteld73 at
Sun Dec 19 03:28:24 GMT 2004

I have set up an Rsync server on FreeBSD 5.3 and plan
on having windows clients synchronize data to it.

Rsync running as a daemon works fine.  I can
successfully  copy data up to the server and view it
via scp.

Also-  I can connect via ssh and run rsync as well.

HOWEVER-  I cannot connect "passwordless" with SSH and
then connect to the rsync daemon.  The following
demonstartes what I would like to do:

rsync -av -e "ssh -l myusername"
rsyncusername at --password-file

When I run the above I successfully authenticate with
SSH but then I get an error that the rsyncd.conf
cannot be read.  Permissions on the rsyncd.conf file

root:wheel -rw-r------

I have tried chown to rsync:rync the user the daemon
runs under as specified in my conf file.

I would like the have the granularity of using

I was somewhat content with just using ssh but ssh
wants to change the permissions on the upload
directory  where others can rwx.  I tried changing the
umask but apparently it is ignored when making an ssh

In addition-  the local accounts on the server are
setup for scponly.  

Any help would be greatly appreciated.  I have been
googling and experimenting for over two weeks.  I
believe everything is proper... :(


Do you Yahoo!? 
Yahoo! Mail - 250MB free storage. Do more. Manage less.

More information about the rsync mailing list