rsync to a destination > 8TB problem...

Matt Miller m.miller at
Tue Aug 10 20:41:56 GMT 2004

I am trying to use a large (10TB) reiserfs filesystem as an rsync 
target.  The filesystem is on top of lvm2 (pretty sure this doesn't 
matter, but just in case.)  I get the following error when trying to 
sync a modest set of files to that 10TB target (just syncing /etc for 

rsync: writefd_unbuffered failed to write 4 bytes: phase "unknown": 
Broken pipe
rsync error: error in rsync protocol data stream (code 12) at io.c(836)

When I encountered the error, I suspected a problem with the filesystem 
size, so I started testing with 2TB, 4TB, 8TB filesystems.  (I started 
with 2TB and grew the LV and resized the reiserfs each time.)  Just 
under 8TB (7.45TB) everything worked fine.  After going just over 8TB 
(8.45TB) I got the error again.

Just for kicks, I tried syncing a single new file and that worked.  I 
then tried syncing a single new directory, and that worked as well.  
You can see below these steps, as well as the directory the original 
/etc sync failed on.  I have listed the contents of that directory and 
the following directory in case it has pertinence here.

Is anyone else using > 8TB targets for rsync with success?  I have kept 
this to a local rsync to eliminate variables with ssh/rsyncd/network.

thanks in advance,


Matt Miller
IT Infrastructure
Duke - Fuqua School of Business
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 1393 bytes
Desc: not available
Url :

More information about the rsync mailing list