Error msg

Jim Salter jim at
Wed Apr 14 18:59:50 GMT 2004

[[email posted back to list with servers and paths obfuscated]]

I notice you aren't specifing a username on the remote machine, 
machine.local.  When using SSH transport, I personally always recommend 
specifying the remote user account; for example 
jennlu at machine.local:/export/path/name/ if the remote account you wished 
to use was "jennlu".

You need to make sure that you can successfully issue the command "ssh 
username at remoteserver" in exactly the same form you specify it in your 
rsync command line, and further make sure that you don't need a password 
to access that account.  If you can't ssh to user at remoteserver without a 
password, rsync won't be able to access it (using SSH transport) either 
- so you'll need to either publish keys and get SSH working properly, or 
set up an rsync daemon and use its transport instead.

Jim Salter
JRS Systems

 > On Wednesday, 14 April 2004 at 10:13, Jim Salter wrote:
 >>Sure looks like it.  You may have something messed up in your path to
 >>the remote machine - you might be a little better off sharing obfuscated
 >>versions of the paths with us when you post problems; for instance using
 >>something like user at remote.pc.ip.address:/path/to/data instead of just
 >><source path>.
 > Sorry not giving enough info.
 > I ran rsync from our designated server, and the path is thru NFS mount,
 > here is what I ran as root:
 > rsync-svl#/usr/bin/rsync --rsync-path=/usr/bin/rsync 
--rsh="/usr/bin/ssh -C" --stats --timeout=43200 -avSH --delete 
/import/path/ machine.local:/export/path/name/
 > /import/path is on another server, but had root trust to the rsync 
 >>Jim Salter
 >>JRS Systems
 >>>I use rsync 2.6.0 version to synchronize 125GB data,
 >>>I got the following error messages by using the following
 >>>/usr/bin/rsync --rsync-path=/usr/bin/rsync --rsh="/usr/bin/ssh -C" 
 >>>--timeout=43200 -avSH
 >>>--delete <source path> <dest path>
 >>>The error messages:
 >>>io timeout after 43200 seconds - exiting
 >>>rsync error: timeout in data send/receive (code 30) at io.c(109)
 >>>Is this network problem?

More information about the rsync mailing list