No such file or directory - error

Dallas Wright gadall at
Thu Sep 11 07:17:07 EST 2003

Hi Wayne,

That worked thanks, now I'm getting a slightly weirder (for me) problem, if
I run

/usr/local/bin/rsync -az --password-file=.secrets data.cdb
dnssynch at
from the system prompt, it works fine, if I put it inside the Makefile for
the data file of tinydns I get
"Makefile", line 5: Inconsistent operator for data.cdb
make: fatal errors encountered -- cannot continue

not sure if this is the best forum for this, but I can't tell if its an
rsync issue or a tinydns issue
----- Original Message ----- 
From: "Wayne Davison" <wayned at>
To: "Dallas Wright" <gadall at>
Cc: <rsync at>
Sent: Tuesday, September 09, 2003 10:34 PM
Subject: Re: No such file or directory - error

> On Tue, Sep 09, 2003 at 08:56:50PM -0700, Dallas Wright wrote:
> > /usr/local/bin/rsync -az --password-file=.secrets data.cdb
dnssynch at
> Since the path is set to /etc/tinydns/root/, this command attempts to
> write a file named /etc/tinydns/root/etc/tinydns/root/data.cdb.  Change
> the destination arg to be just "tinydns/data.cdb" after the "::" and all
> should be well.
> > it returns me to the system prompt with no errors or warnings.
> The version in CVS properly outputs a warning to the user, so it looks
> like that bug is fixed for the next version (though I can't find it
> mentioned in the NEWS -- hmm).  There have also been some changes to
> improve the mkstemp error (to make it contain the full path to the temp
> file), but I note that it needs a little more improvement to handle
> daemon mode -- I'll look into that.
> ..wayne..

More information about the rsync mailing list