v2.5.6 on AIX and large files

Robert Cross Robert.Cross at scottish-courage.co.uk
Mon Oct 20 21:11:59 EST 2003

Abstract: Looking for technical assistance with rsync version 2.5.6
protocol 26 on AIX.

Trying to use rsync (version 2.5.6) to sync two AIX-based systems the other
day, and a couple of the filesystems (7 out of 18 in total) gave the
following error message:

      rsync: writefd_unbuffered failed to write 32768 bytes: phase
"unknown": Broken pipe
      rsync error: error in rsync protocol data stream (code 12) at

Typical command used was:
      rsync --archive --whole-file --one-file-system /sapdb/SP1/data6
sap06:/sapdb/SP2 2>> $logfile
and the network interface being used was Gigabit Ethernet, the disk in both
cases being hosted on an SAN system. So there's plenty of disk and LAN

I've Googled for this problem, and the only references I can find for it,
seem to imply either LAN/IP-stack problems or problems with the source
data. I've got a problem believing either of these since:
a. I managed to send the failing file systems quite successfully using
standard "rcp" (remote copy) command. In fact rcp was twice as fast as
rsync (23MB/s+ v's 10-11MB/s) which I'm worried about.
b. No other problems noted with intersystem comms or these filesystems.
c. Other file systems which worked fine with rsync contained more data -
and were therefore larger - than some of the failing ones, so it's not a
file system size issue.

At the time I tried playing with some of the rsync parameters, dropping
--whole-file and adding --partial, with no success. Oh, and I'm not using
an rsync server/daemon nor ssh.

I've now done some more digging and all the filesystems that failed to sync
contain one or more files that are larger than 2GB in size. So it looks to
me like the latest version, on AIX at least, isn't large file

If anyone's got any flashes of inspiration on either the large file
"problem", or the lack of performance, I'd be really


Bob Cross.

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
This message is confidential.  It may also be privileged or
protected by other legal rules.  It does not constitute an
offer or acceptance of an offer, nor shall it form any part
of a legally binding contract.  If you have received this
communication in error, please let us know by reply then
destroy it.  You should not use, print, copy the message or
disclose its contents to anyone.

E-mail is subject to possible data corruption, is not
secure, and its content does not necessarily represent the
opinion of this Company.  No representation or warranty is
made as to the accuracy or completeness of the information
and no liability can be accepted for any loss arising from
its use.

This e-mail and any attachments are not guaranteed to be
free from so-called computer viruses and it is recommended
that you check for such viruses before down-loading it to
your computer equipment.  This Company has no control over
other websites to which there may be hypertext links and no
liability can be accepted in relation to those sites.

Scottish Courage Limited
Registered in Scotland, Registered Number 65527
Registered Office: 33, Ellersly Road, Edinburgh, EH12 6HX
Head Office: 160 Dundee Street, Edinburgh, EH11 1DQ
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

More information about the rsync mailing list