rsync 2.5.6 hanging in cygwin on Windows shares

John Hunt john.rsync at
Tue Nov 18 05:53:52 EST 2003

rsync 2.5.6 is hanging in cygwin, at the end when it should print a summary of 
bytes sent etc and exit. It has successfully copied all the files before 

It does this every time when copying to or from a Windows share. (It sometimes 
hangs when copying from one local drive location to another, but I have not 
tested this as thoroughly.)

The Windows shares are almost certainly on Windows machines, probably win 
2000, but are not within my control (managed by an out-sourced IT dept).
I am running cygwin on a Windows 2000 PC.

I have worked around this by reverting to rsync 2.5.5 that has always worked 
perfectly for me.

The suggested rsync.exe replacement at also hangs.

(If you need more details, eg exact rsync command I am using, please ask.)

Apologies if this problem is already known about; I searched the archives but 
found nothing that quite matches what I have observed.

John Hunt
Stokesley, N Yorks, UK
e-mail: john.rsync at

More information about the rsync mailing list