unable to connect over ssh when using an other user than root

Ronney Ronney at rorotec.ch
Fri May 9 05:55:33 EST 2003


I'm using rsync version 2.5.6.
When i try to connect from a remote computer for example with,
rsync -e ssh root at
it connects and tells me what paths are available.
But when i want to connect with a normal user
rsync -e ssh user at
it tells me following error message:

rsync: unable to open configuration file "rsyncd.conf": No such file or directory
rsync error: syntax or usage error (code 1) at clientserver.c(502)
rsync: connection unexpectedly closed (0 bytes read so far)
rsync error: error in rsync protocol data
stream (code 12) at io.c(165)

but the file rsyncd.conf exist! (i can use it with root ;))

first i tried to copy the conf file to /etc/rsync/rsyncd.conf but it
didn't help anything.
so i tried to copy the rsyncd.conf file from the /etc directory to the
user's home directory. And now it works. But it's not a really clean
What could be the error?



More information about the rsync mailing list