rsync and cygwin

jw schultz jw at
Sun Jun 8 08:09:38 EST 2003

On Sat, Jun 07, 2003 at 10:49:03AM -0500, Trey Nolen wrote:
> I had sent a message to the list earlier this week detailing an error
> message I am getting using rsync on Cygwin on Windows 2000.  I have now
> duplicated the problem on another windows 2000 server. I have a third server
> on which the process works, so I don't really know what is going wrong.  All
> three servers are rsyncing to the same Linux server.  Below is the original
> question. Any help would be appreciated.
> The error is this:
> Invalid file index <some number> (count=<some number>)
> rsync error: protocol incompatibility (code 2) at sender.c (135)
> The command line I'm using to start this is:
> c:\cygwin\bin\rsync -aR -e
> c\cygwin\bin\ssh.exe -v --numeric-ids --exclude-from=/cydrive/c/ssh/rsync-ex
> cludes.txt --dry-run --delete --delete-after /cygdrive/c root at
> backupserver:/
> rsync-excludes.txt  contains things like:
> :
> :
> At first I thought that maybe my file list was getting too long, but I
> changed my excludes so that I had a file list that I knew was short enough
> and I still get the error. I get the error on different files depending on
> what I have excluded, but if I run the same command twice,  I get the error
> in the exact same spot.  Thanks in advance for any help.

That error indicates something is seriously wrong at the
communications level.  Given an ssh over TCP connection i'd
rule out the network layer.  That leaves internal data
corruption.  I'd start by questioning the integrety of the
common point of failure--the backup server.  Check the logs
for errors, run memtest, etc.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt

More information about the rsync mailing list