rsync and cygwin part II

Trey Nolen tnolen at
Thu Jun 5 11:18:21 EST 2003

OK, I had emailed yesterday about an issue backing up a W2K machine using
rsync under Cygwin. I was having trouble backing up the root directory, and
I'm happy to say that the suggestion of using /cygdrive/c seems to have

Unfortunately, now I'm getting another error.  The error is this:

Invalid file index <some number> (count=<some number>)
rsync error: protocol incompatibility (code 2) at sender.c (135)

The command line I'm using to start this is:
c:\cygwin\bin\rsync -aR -e
c\cygwin\bin\ssh.exe -v --numeric-ids --exclude-from=/cydrive/c/ssh/rsync-ex
cludes.txt --dry-run --delete --delete-after /cygdrive/c root at backupserver:/

rsync-excludes.txt  contains things like:

At first I thought that maybe my file list was getting too long, but I
changed my excludes so that I had a file list that I knew was short enough
and I still get the error. I get the error on different files depending on
what I have excluded, but if I run the same command twice,  I get the error
in the exact same spot.  Thanks in advance for any help.

Trey Nolen

More information about the rsync mailing list