Question regarding exclude and invalid arg messages

Morten Primdahl morten at
Wed Jul 2 18:03:00 EST 2003

 >>Tried to enable -vvv but this makes rsync hang on the same file each
 > -vvv is known to cause hanging.  It is, however the
 > verbosity level needed to get some info out of that part of
 > the code.  Lets not try to debug the hang.  Reduce the level one notch.
 > Narrow the scope somewhat. And answer the questions asked in
 > my previous email.

I still get some garbage on stderr:

.qsJ4iC failed: Invalid argumentsp_ind/Emails ind/.Icon
.klS8j3 failed: Invalid argumentsp_ud/Emails ud/.Icon

The garbage lines only come for the .Icon folder.

But also more valid messages like (still on stderr):

mkstemp 2001_12_Villa_OpNed/01_Korrespondance ind/01 Bygherre/Emails/.Villa "up and go".1.N0LkFe failed: Invalid argument
mkstemp 2001_12_Villa_OpNed/01_Korrespondance ind/01 Bygherre/Emails/.nyt på tegnefronten?.1.8ZzfZ6 failed: Invalid argument

If I look for these files on the source filesystem, I find that:

[samba at fserv SAGER_igangvaerende]# find . -name "Villa*up and go*"
./2001_12_Villa_OpNed/01_Korrespondance ind/01 Bygherre/Emails/.AppleDouble/Villa "up and go".1
./2001_12_Villa_OpNed/01_Korrespondance ind/01 Bygherre/Emails/Villa "up and go".1

And as I have .AppleDouble in my exclude file (no trailing slash), the problem appears
to be due to my naive usage of the exclude file. As far as I under stand now, the
behaviour is due to the .AppleDouble directory not getting created on the destination,
and due to the lacking slash in the exclude file, rsync still tries to copy the files within
this directory. The only thing I do not understand now, is the prepended dot, so eg. Villa
becomes .Villa.



More information about the rsync mailing list