small problem that I'm having...

Patrick Amirian pamirian at
Wed Jan 29 01:57:17 EST 2003

Well I have no permission problems... I'm running my commands as root.

With path = /a/b/ it didn't work but it worked with path = /a/b/*

-----Message d'origine-----
De : at
[ at] De
la part de jw schultz
Envoyé : 28 janvier, 2003 09:39
À : rsync at
Objet : Re: RE : RE : small problem that I'm having...

On Tue, Jan 28, 2003 at 09:00:35AM -0500, Patrick Amirian wrote:
> FYI.
> Yeah actually I found my mistake.
> In the config file I had path=/blah/blah/
> The real thing is path=/blah/blah/*
> It worked.

Poor solution.  Common error.  Much better to fix the
permissions on /blah/blah

Using * means that it will do shell expansion and not match
any dot files the top level directory.  That may be
acceptable in some cases but don't try it on home
directories or web server trees with .htaccess files.

Using * as shorthand for all files and dirs with rsync and
similar tools is a bad habit that will bite you in the
anterior when you are least expecting it.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt
To unsubscribe or change options:
Before posting, read:

More information about the rsync mailing list