Help With Restoring

mhanze at mhanze at
Fri Jan 10 19:49:00 EST 2003

"Dr. Poo" <drpoo at> wrote on 01/11/2003 09:25:18 AM:

> I'm very interested in this...
> My question(s) are why did you have to install a minimal system?
> Could you have just booted up with network and rsync and just rsynced to 
> freshly paritioned/formatted disk?

And your probably right but I wasn't comfortably clear on how and my time 
to at least get the web server up was short. I did try to boot off the 
floppy I made back when I first installed the system but that didn't work. 
So I decided to get myself into a working environment with all the pieces 
needed like a shell, networking, rsync, and anything else a minimal 
install will do to make things work. 

> What command did you use (to clarify) to make the original rsync's of 
> disk, and what were the steps neccessary and the command you used (to 
> clarify) to make the restore? (I guess that includes the install of a 
> system.. did you use the same system, say redhat 7.2?)

Well I'm sure these steps might look silly to the experienced but it 
worked and saved a years worth of my investment in learning, research and 
development on this box :)

This started trying to upgrade to Redhat 8.0 with the Kernel on the CD 

Client Server...
Linux version 2.4.18-3smp (bhcompile at (gcc version 
2.96 20000731 (Red Hat Linux 7.3 2.96-110)) #1 SMP Thu Apr 18 07:27:31 EDT 
MemTotal:       126116 kB
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III CPU family      1133MHz
stepping        : 1
cpu MHz         : 1130.497
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca 
cmov pat pse36 mmx fxsr sse
bogomips        : 2254.43

Here is the script I used to back up to a central server:

DAY=`date +%A`
export PATH DAY
[ -d /root/emptydir ] || mkdir /root/emptydir
rsync --rsh=/usr/bin/ssh --delete -a /root/emptydir/ 
rmdir /root/emptydir
rsync --delete --stats --compress --recursive --times --perms --links 
--rsh=/usr/bin/ssh --exclude "tmp/" --exclude "dev/" --exclude "proc/" 
--exclude "backups/ " --delete-excluded --backup 
--backup-dir=/backup2/BACKED_UP_SERVER_FQDN/$DAY -a /* 
CENTRAL_SERVER_IP:/backup2/BACKED_UP_SERVER_FQDN/current && echo "Daily 
backup ran on `date`" >> /var/log/backup.log

Here is the schedule:

0 2 * * * /etc/cron.customs/backups

Here is the central backup server:

Linux version 2.4.7-10 (bhcompile at (gcc version 
2.96 20000731 (Red Hat Linux 7.1 2.96-98)) #1 Thu Sep 6 17:27:27 EDT 2001
MemTotal:       255344 kB
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 0
model name      : Intel(R) Pentium(R) 4 CPU 1400MHz
stepping        : 10
cpu MHz         : 1395.777
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca 
cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss tm
bogomips        : 2785.28

OK. So now I lost my client server...

1) Booted the server off of the Redhat 8.0 Disk 1  of 3

2) Custom Install

3) Manually Partition with Disk Druid

        All the partition information was already there. The path was 
missing but when I went into edit each partition, all i had to do was 
click the drop down arrow twice to populate the path field with the 
original. I choose to format each partition. (I was also able to confirm 
my partition table by looking at my last backup stored on the central 
server /etc/fstab. Nice to have if a new disk was required :)

4) Choose Minimal System on the Package Selection page

5) Added myself to the system

Let er rip

After the install and reboot

6) signed on as me and got to a command line

$ su
# cd /
# rsync -avv --rsh=/usr/bin/ssh 

Because I was root, it asked for the root password on the server. I 
watched as it tailed through all the files being rsync'd. When it was 

# /sbin/shutdown -r now

And it came back up as if nothing has happened, so I hope :-/ So far so 
good though :)

> I'm curious because i have a full rsync of a production server on my 
> development box, and i put it in Lilo to boot up with, disconnected the 
> network (so know conflicts occur, would any?) and tried to boot, but it 
> failed... (i don't have access right now to the error message).
> The production box is i686 and so is the development box... Not the same 

> processor though.... would that make a difference?

I doubt that your processor mismatch can be an issue.

> Do you think if i just tried to install a minimal system to a partion 
> copied the / tree it would work??

Like i said before, I'm not very experienced in Linux, although gaining on 
it. My playgrounds have been Windows, AS/400's and iSeries boxen. What 
worked for me MAY work for you and I hope it can.

>    Thanks a bundle! Great job on the success!! And Good luck for the 
>       -Chris

Thanks! The future looks promising. This restore really gave me a good 
feeling. Things seem to work better when we share!


-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list