Problem with rsync from one machine

jw schultz jw at
Fri Feb 7 09:08:33 EST 2003

On Thu, Feb 06, 2003 at 03:01:07PM -0600, Tom Walsh wrote:
> I am not sure where to begin so I will be as verbose as I can to explain the
> problem.
> I have 3 servers. Their specs are:
> Machine A: Redhat 7.1 kernel 2.4.9-34 openssh 3.1p1-5
> Machine B: Redhat 7.3 kernel 2.4.9-31 openssh 3.1p1-5
> Machine C: Debian Woody kernel 2.4.18-bf2.4 openssh 3.4p1 rsync 2.5.6

rsync 2.5.6 on machines A and B?

> I am running an rsync over ssh from Machine C to Machine B with the
> following:
> rsync --verbose --progress --stats --compress --rsh=/usr/bin/"slogin -l
> root -o Compression=yes" --recursive --times --links --perms --owner --group
> /backup/
> This works flawlessly.
> When I run an rsync over ssh from Machine C to Machine A with the following:
> rsync --verbose --progress --stats --compress --rsh=/usr/bin/"slogin -l
> root -o Compression=yes" --recursive --times --links --perms --owner --group
> /backup/
> The following occurs:
> All directories on Machine A /etc are replicated on Machine C
> /backup.../etc, however when the process starts to transfer files from
> Machine A, I get:
> receiving file list ...
> 650 files to consider
> etc/
> etc/.pwd.lock
>   30888880 0%   8.82MB/s 538:49:00
> Looks pretty normal, except the fact that /etc/.pwd.lock is a 0 size file...
> So I am not sure where it is getting all that data from.
> This occurs with any directory I specify, same result.

Any directory?  What do you mean by that?  This hapens to
the first file in every directory? Zero lenghth files?
.pwd.lock is all over?  I'm not really familiar with that
particular file but i do have one on my SuSE systems but
only in /etc

> I have looked both installs... and I really can't seem to find out why one
> works and the other does not.
> I started looking at the file systems... and Machine A is ext2 Machine B is
> ext3 and Machine C is also ext3, but I can't see how that would matter... I
> am just grasping for straws here.
> Does anybody see why it works with one machine but not another?
> Any guidance is appreciated.

Someone else has suggested using strace.  Good idea but you need
to push (initiate the rsync on "A") for that to do much good.

Perhaps something is just really strange.

Start with a ls -sl .pwd.lock.  Anything odd?

cat /dev/null >.pwd.lock

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt

More information about the rsync mailing list