Problem with rsync from one machine

Tom Walsh slim at
Fri Feb 7 08:01:07 EST 2003

I am not sure where to begin so I will be as verbose as I can to explain the

I have 3 servers. Their specs are:

Machine A: Redhat 7.1 kernel 2.4.9-34 openssh 3.1p1-5
Machine B: Redhat 7.3 kernel 2.4.9-31 openssh 3.1p1-5
Machine C: Debian Woody kernel 2.4.18-bf2.4 openssh 3.4p1 rsync 2.5.6

I am running an rsync over ssh from Machine C to Machine B with the

rsync --verbose --progress --stats --compress --rsh=/usr/bin/"slogin -l
root -o Compression=yes" --recursive --times --links --perms --owner --group /backup/

This works flawlessly.

When I run an rsync over ssh from Machine C to Machine A with the following:

rsync --verbose --progress --stats --compress --rsh=/usr/bin/"slogin -l
root -o Compression=yes" --recursive --times --links --perms --owner --group /backup/

The following occurs:

All directories on Machine A /etc are replicated on Machine C
/backup.../etc, however when the process starts to transfer files from
Machine A, I get:

receiving file list ...
650 files to consider
  30888880 0%   8.82MB/s 538:49:00

Looks pretty normal, except the fact that /etc/.pwd.lock is a 0 size file...
So I am not sure where it is getting all that data from.

This occurs with any directory I specify, same result.

I have looked both installs... and I really can't seem to find out why one
works and the other does not.

I started looking at the file systems... and Machine A is ext2 Machine B is
ext3 and Machine C is also ext3, but I can't see how that would matter... I
am just grasping for straws here.

Does anybody see why it works with one machine but not another?

Any guidance is appreciated.

Tom Walsh
Network Administrator

More information about the rsync mailing list