Bug on cygwin?

John Hunt john.rsync at yoredale.uklinux.net
Mon Dec 22 02:43:51 EST 2003

On Saturday 20 Dec 2003 13:18, Douglas Beethe wrote:
> When using the cygwin version of rsync for archive ops on a Windows
> subnetwork in "local" mode as follows:
>     rsync -a xyz //somehost/abc     # Source: WinXP,  Target: Win2K
> the correct files seem to be copied to the target machine, but the
> command never terminates within the cygwin bash shell.  It hangs
> indefinitely, though it does not appear to continue using CPU or memory
> resources.  I have to kill the shell window to terminate the operation.
> Anyone else seeing this?

Yes, a well known problem.

See for example thread entitled "cwRsync 2.5.7" dated 2003-12-10.

Tevfik Karagülle (see aforementioned thread) has released a fixed version - I 
have not yet tried it but hope to do so in the next day or two.

I have reverted to rsync 2.5.5 that has always worked reliably for me in 
cygwin, but from this list I understand that some people have problems with 
that version too.

John Hunt
Stokesley, N Yorks, UK
e-mail: john.rsync at yoredale.uklinux.net
URL: http://www.yoredale.uklinux.net/

More information about the rsync mailing list