Rsync Troubles after NAT router firmware Upgrade.

Corey Johnson cjohnson at
Tue Dec 2 11:07:42 EST 2003


I have been using rsync for a long time to send web files from a development
server to a production server. It worked great
until a few days ago when I upgraded the firmware on the Linksys BEFSR11
Router that the production server is behind. The development server is also
behind the same model router, and both servers are connected to the cable
network (Internet) using Surfboard cable modems.

I tried playing with the different options, changing router settings,
tunneling through SSH, and I even upgraded the firmware on the other router.
I upgraded my RPM from 2.5.5 to 2.5.6 but still no luck.

Here's the Problem:

When I run  "rsync -avvvv /www/static/", it runs
through making the file list, which is very slow. It finishes
that though, and then it gets done and here is where it seems like it hangs:

generate_files phase=1
recv_files( The Heavens.mp3) The Heavens.mp3
data recv 32768 at 0
data recv 32768 at 32768
data recv 32768 at 65536

At that point, it has been sitting here for almost 30 minutes since I
started the command. That Mp3 file there is about 3 MB. When I rsync the
HTML files, it actually finishes syncing, but it takes a VERY long time. The
Internet connections appear to be
working fine between the two servers, running Netstat on either end shows
that there is an rsync connection, and the rsync process is running on both
ends. Tunneling through SSH and changing the options produces the same

 I searched the web and I saw there were some issues
concerning these routers and rsync, but none of them seemed to apply to my

I can successfully rsync between 2 dirs in the filesystem or 2 machines on
the same LAN, but not over the Internet through
the routers. Ports 873 and 22 are fowarded on both routers to the proper IP

Any help would be greatly appreciated!  I will change my network setup
before I will use FTP/SFTP to transfer files!

The setup:

Production Server (I am rsyncing to):

Linksys Router BEFSR11 With Firmware Version 1.45.7 (Jul 31 2003)
RedHat Linux 9.0
rsync 2.5.6
kernel 2.4.20

Development server (I am rsyncing from):

Linksys BEFSR41 Router with Firmware Version 1.45.7 as well.
RedHat Linux 8.0
rsync 2.5.5
kernel 2.4.14

My Internet connection is a cable connection, and the two machines connect
to the same local cable network (they are only
about 3 miles apart from each other. I don't think that my ISP has anything
to do with it. I have tried pushing data to the production server (run
rsyncd on the production server) and pulling it from the development server
(run rsyncd on dev server)..neither worked. Again, this worked fine until I
did that firmware upgrade.

More information about the rsync mailing list