unexpected tag 25 on OSX

jw schultz jw at pegasys.ws
Wed Apr 30 10:39:28 EST 2003

On Tue, Apr 29, 2003 at 12:10:37PM -0700, Michael Fairchild wrote:
> Sorry for the identical post, I got confused and thought
> the first one didn't go through.
> Anyways, I'm sitll working on it.  I have tried the #undef
> HAVE_SET_GROUPS hack, and now make check passes, but i
> still get the ame error:
> expand file_list to 512000 bytes, did move
> expand file_list to 512000 bytes, did not move
> unexpected tag 25
> rsync error: error in rsync protocol data stream (code 12) at io.c(315)

Unexpected tag inidcates a serious communications problem.

> I was thinking my problem might be similar to Steve
> Dekorte's.  If your still out there, was there something
> else you had
> to do in addition to the HAVE_SET_GROUPS hack?
> Thanks,
> Michael Fairchild
> On Mon, Apr 28, 2003 at 09:29:39PM -0700, Michael Fairchild wrote:
> > Hello, I am trying to set up a rsync backup server.  So
> > far I have it working with my linux machines.  I am now
> > trying to get it to work with OSX.2.  From my backup
> > server i am executing "rsync --delete --progress --stats
> > -avRe ssh --exclude=/Volumes/  --numeric-ids
> > client.mydomain" and using an ssh key with the
> > command="rsync --server --sender -vlogDtprR --delete
> > --numeric-ids . /" I keep getiing an "unexpected tag 25"

I cannot recommend putting the rsync command itself here.
wrap it in a script that execs the, possibly modified,
original command which is in an environment variable.

> > error.  Does anybodyu know what tag25 is? or where i
> > could find out?  I have tried the command without the
> > command= in the key to make sure it wasn't the problem.
> > The strange thing is that when i run the same command
> > above, but instead of trying to backup / i do /Users/,
> > it works.  i.e. "rsync --delete --progress --stats
> > -avvvRe ssh --exclude=/Volumes/  --numeric-ids
> > client.physics.ucla.edu:/Users/ /mn$ I am running the
> > job as root on both machines.  Could this error have
> > something to do with the HFS filesystem?  Any ideas?

Be careful testing as root.  If you are getting
unexpected tag errors the filelist could be get munged and
you'd overwite the wrong file.

Until you get rid of the unexpected tag errors don't try to
force ssh command restriction.  Get it working over ssh
first, then apply restrictions.

I'd look into what version of ssh you are running,  Solaris
people are apparently having problems with the shipped
version.  You might try rsync --blocking-io, although ssh
works better with non-blocking.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at pegasys.ws

		Remember Cernan and Schmitt

More information about the rsync mailing list