Connection refused

jw schultz jw at
Tue Apr 29 11:24:24 EST 2003

On Mon, Apr 28, 2003 at 06:05:40PM -0700, Steve Dekorte wrote:
> On Monday, April 28, 2003, at 05:57 PM, Steve Dekorte wrote:
> >% rsync -av --progress localhost::io .
> >@ERROR: setgroups failed
> >rsync: connection unexpectedly closed (37 bytes read so far)
> >rsync error: error in rsync protocol data stream (code 12) at io.c(165)
> >
> >I don't see anything in the man page about this error. I did find a 
> >mention in the archives(from Feb) though as an OSX specific bug. Is 
> >this still broken? I'll try the workaround mentioned.
> I tried the OSX fix mentioned here:
> But I still get the same error. Any ideas?

You mean that you edited config.h and changed
"#define HAVE_SETGROUPS 1" to "#define HAVE_SETGROUPS 0"
and rebuilt but still get "@ERROR: setgroups failed"?

If that is the case run make clean.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt

More information about the rsync mailing list