File size limitations?

Nigel Barker nigelb at
Sat Apr 12 02:20:14 EST 2003


Thanks for the pointer.

I tried changing the mount to nfs2, no change, so I assume its down to
setting "HAVE_OFFSET64_T" and recompiling.

I've been able to recompile the code, seems to go through fine, but produces
a binary which is more broken than the one I had!

Could you say how and where I should set HAVE_OFFSET64_T - I tried putting
it in rsync.h as
#define HAVE_OFFSET64_T 1
but that doesn't seem to have done the trick.



-----Original Message-----
From: at
[ at]On Behalf Of jw
Sent: 10 April 2003 21:37
To: rsync at
Subject: Re: File size limitations?

On Thu, Apr 10, 2003 at 01:46:55PM +0100, Nigel Barker wrote:
> Hi
> I'm running rsync 2.5.6 protocol version 26 on solaris 8.
> I have a local software RAID array, plus a mounted netapp fileserver, and
> looking to replicate the contents of the netapp mount on the RAID array.
> readlink staff/ex_staff/mickie_mouse.tar.Z: Value too large for defined
> type

Old, known problem.  Sun mtime bug.

or google groups for 'rsync "Value too large"'

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt
To unsubscribe or change options:
Before posting, read:

More information about the rsync mailing list