bug report: bus error on Mac OS/X 10.2.3

jw schultz jw at pegasys.ws
Wed Apr 2 14:41:12 EST 2003

On Tue, Apr 01, 2003 at 10:43:55PM -0500, Daniel Barrett wrote:
> When I run "rsync -a" to mirror a large directory structure on Mac OS/X
> 10.2.4, it always (100%) produces a bus error. Small directory structures
> work fine.
> The computer in question has 768 MB RAM and 10 GB free disk space, so
> memory is not a problem.  This is rsync 2.5.2 supplied with Mac OS/X.
> The command I ran today was:
> SRC=/
> DEST=/Volumes/AlbusBackups
> sudo rsync -av -n --exclude "/Volumes/Work" --exclude "$DEST" "$SRC" "$DEST"
> The error message simply said "Bus error" and echoed the rsync command line
> above.

This looks like it could as easily be a libc bug.  Be that
as it may you are running a old version of rsync.
Current releases version is 2.5.6.  You should upgrade.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at pegasys.ws

		Remember Cernan and Schmitt

More information about the rsync mailing list