How to debug Fw: Rsync fail repeatedly on the same files.

addady at addady at
Tue Sep 10 08:22:01 EST 2002

Hello Again,

Following my previous post (attach in this email).
I didn't find yet any clue why it happen and what going on is those

I'm would like to go deep into it by trying to debug this issue.
I need some redirection how to start and activate the debugger etc.

Any help will be appreciated


----- Original Message -----
From: "Addady" <addady at>
To: <rsync at>
Sent: Sunday, September 08, 2002 4:24 PM
Subject: Rsync fail repeatedly on the same files.

> Hello,
> I’m trying to rsync Windows 2000 to Linux.  It fail on the same file every
> in every try.
> If  I delete from the source the problematic file, then it fail again
> a while on other file.  The file size vary etc.
> I install rsync on other Linux for test, and there was no problem to rsync
> the entire directory to this new destination.
> The error message on the client site is some thing like this:
> rsync: error writing 14957 unbuffered bytes - exiting: Connection reset by
> rsync error: error in rsync protocol data stream (code 12) at io.c(463)
> I’m running 2.5.5 on both sides.
> Tried to use --partial  and it still fail.
> I install on the client side the cygwin patch for “connection reset by
> with no help.
> I even download on the server side rsync version to 2.5.2 and it’s the
> problem.
> It seems that the problem is on the server side.  This is our backup
> located on ISP facility over seas.
> Please advaise.
> Addady

More information about the rsync mailing list