rsync -e ssh does not work well

Kauko Heikkila Kauko.Heikkila at
Fri Oct 25 15:31:01 EST 2002

From: "jw schultz" <jw at>
To: <rsync at>
Sent: Friday, October 25, 2002 5:04 PM
Subject: Re: rsync -e ssh does not work well

> On Fri, Oct 25, 2002 at 04:33:54PM +0300, Kauko Heikkila
> >
> > One more, serious problem exists, since
> > when invoked from a w2000 laptop
> > (servername is still the same SuSe Linux server)
> >
> > rsync -trvuz   file.wrk uname at servername::uname-html
> > works, but
> > rsync -trvuz  -e ssh  file.wrk
> > uname at servername:public_html/
> > does not.
> >
> > "unexpected EOF in read_timeout"
> The version of rsync on you laptop 2.4.6? is quite old
> many bugs have been fixed since.  Normally we would
> you start by upgrading to the latest version, either
2.5.5 or
> CVS.  Supporting obsolete bugs is a pain.

Thanks. I will return afer new installations.

> The nearest report i could find in the last few months
> matches your description was caused by the remote shell
> establishing a connection.  Try just doing an
> ssh servername rsync --version
> to confirm that much works.  This will confirm that not
> does ssh connect but that it can find rsync.

I have tried that, ssh connects and finds rsync!

> Instead of attempting to quote, provide us the real log
> output from rsync.
> I don't have any windows systems so someone else may be
> help here.

I  shall return,  thank you for answering,

More information about the rsync mailing list