rsync 2.5.5 segmentation fault on Linux x86.

Paul Haas paulh at
Tue Oct 1 16:00:02 EST 2002

On 1 Oct 2002, Erik Enge wrote:

> Hi all.
> I have a script which I call from cron.  It basically does some stopping
> of a few services, rsyncs all files to a remote server and then starts
> the services again.  However, rsync segfaults:
>   /share/bin/ line 28: 18453 Segmentation fault      rsync -acx --delete ${_backup_dirs} backup-server::backup-client
> If I run rsync from the command-line everything works as expected and no
> segmentation fault.

This isn't specific to rsync.  When I've had cron jobs that fail, but wrk
interactively, I add something like this to the script:

  echo this is try 1 of on >> /tmp/$$.debug
  date >> /tmp/$$.debug
  printenv >> /tmp/$$.debug
  ulimit -a >> /tmp/$$.debug
  echo the rsync I'll get is >> /tmp/$$.debug
  type rsync >> /tmp/$$.debug
  whoami >> /tmp/$$.debug

Then I run it once interactively and once through cron and compare stuff.

Usually it's pretty obvious which environment variable is the problem.

> I'm really lost where to start debugging this problem, has anybody else
> seen this before and would be able to give me a hint?
> It's rsync 2.5.5 compiled from source with gcc 2.96 on RedHat Linux 7.2.
> Thanks for any pointers,
> Erik Enge.
> --
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list