rsync 2.5.5 segmentation fault on Linux x86.

Trevor Marshall tm at
Tue Oct 1 15:12:00 EST 2002

2.5.5 rsync crashes and burns my hard disk, you are indeed lucky to get a
segmentation fault.

When I reported flakiness I was told it was my hardware. I upgraded my
hardware - no difference.

Then I was told to change my 2.4.x kernel. Why? it runs everything else,
and has reliably for over a year?

Yet every time I run rsync to back up from /dev/hda1 to /dev/hdc1 it
crashes and takes the whole system down. 

cp of the same filesystem works, but not rsync. Depending on the number of
"v"s and the --exclude options it crashes at different points in the
process. While rebooting I often have to fsck from "maintenance mode". That
is not nice. In fairness, though, I am backing up a heck of a lot of files.

So I wish you luck with your cron segmentation faults. But the above are my
observations. With SuSE Linux, not RedHat 7.2. Although you would likely be
running a similar kernel version to mine:
"Linux version 2.4.10-4GB (root at (gcc version 2.95.3
20010315 (SuSE))"

I keep hoping the next version has somehow gotten this fixed...

(Dr) Trevor G Marshall
Contributing Editor,

At 09:47 AM 10/1/2002 -0400, you wrote:
>Hi all.
>I have a script which I call from cron.  It basically does some stopping
>of a few services, rsyncs all files to a remote server and then starts
>the services again.  However, rsync segfaults:
>  /share/bin/ line 28: 18453 Segmentation fault
rsync -acx --delete ${_backup_dirs} backup-server::backup-client
>If I run rsync from the command-line everything works as expected and no
>segmentation fault.
>I'm really lost where to start debugging this problem, has anybody else
>seen this before and would be able to give me a hint?
>It's rsync 2.5.5 compiled from source with gcc 2.96 on RedHat Linux 7.2.
>Thanks for any pointers,
>Erik Enge.
>To unsubscribe or change options:
>Before posting, read:

More information about the rsync mailing list