Rsync service on Win2k?

John Morgan Salomon john at
Fri Nov 29 16:29:02 EST 2002

Hi all,

I'm trying to get rsync running on a Windows 2k box (my tape backup 
server) to remotely
back up stuff from a few unix boxes.  Not my favored constellation, but 
there's not
much I can do about that.

I'm hoping someone could give me a quick tip or two on getting rsync working
as a Win2k service.  I'm not real proficient with Win2k, so be gentle. 
 The posts I could
find in the archive all seeem to have gotten past this basic problem!  

I've installed the latest Cygwin, as well as the Cygwin rsync package.

cygrunsrv -I "rsyncd" -d "Rsync daemon" -p /usr/bin/rsync.exe -a 
"--config=/etc/rsyncd.conf --daemon"
installs the service;  rsyncd.exe --config=/etc/rsyncd.conf --daemon 
runs it from a bash shell,
but I can't seem to start it either using cygrunsrv -S "rsyncd", or from 
the Services manager.

I've also tried with --no-detach and -e CYGWIN='binmode tty ntsec' on 
the cygrunsrv command line,
as described at

Lastly, I tried getting it running via srvany.exe (from the Win2k 
resource kit) and srvinstw, with
even less intelligible output.

Any help would be very much appreciated.



cygrunsrv's error message:

$ cygrunsrv -S "RSYNC"
cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062:
The service has not been started.

Here's the Win2k event viewer log:

Event Type:    Error
Event Source:    RSYNC
Event Category:    None
Event ID:    0
Date:        11/29/2002
Time:        5:15:26 PM
Computer:    SISB0006PFS
The description for Event ID ( 0 ) in Source ( RSYNC ) cannot be found. 
The local computer may not have the necessary registry information or 
message DLL files to display messages from a remote computer. The 
following information is part of the event: RSYNC : Win32 Process Id = 
0xA08 : Cygwin Process Id = 0xA08 : starting service `RSYNC' failed: 
execv: 255, error 255.

More information about the rsync mailing list