Owner and permissions problems when syncing w2k<->w2k

Greger Cronquist greger_cronquist at yahoo.se
Thu Nov 14 18:43:00 EST 2002


I'm having a bit of a problem setting up an rsync
operation between two Windows 2000 servers. On one of
the machines I have started an rsync Daemon (service,
started as administrator) using the lines below.

On the other machine I do a 

rsync -Pzrtvpo /cygdrive/d/root/Folder
administrator at

What happens is that all transferred files (no problem
with the actual transfer) get owned by SYSTEM with no
permissions for anybody else. I have tried to use "Log
On As" to change the user (to the administrator), but
if I do that the daemon won't start at all.

I have also tried to changing the cygwin environment
ntea to ntsec (and both).

In my log-file I occasionally get a 

2002/11/14  [2056] rsync error: received SIGUSR1 or
SIGINT (code 20) at /tmp/rsync-2.5.5/rsync.c(229)

All hints are more than welcome!

TIA, Greger Cronquist

-- Server side:

cygrunsrv.exe -I "rsyncd" -d"RSYNC Backup Daemon"
--path /cygdrive/c/rsync/rsync --args
'--config=/cygdrive/c/rsync/rsyncd.conf --no-detach
--daemon' -e CYGWIN='binmode tty ntea'

and the config file:

log file = /cygdrive/c/rsync/log.txt
use chroot = false
strict modes = false

path = /cygdrive/d/root
comment = d-drive
read only = false
#uid = administrator
list = true
auth users = administrator
secrets file = /cygdrive/c/rsync/passwords.txt
transfer logging = true
hosts allow = ndserv1
dont compress = *.rar *.zip

Gratis e-mail resten av livet på www.yahoo.se/mail

More information about the rsync mailing list