Speed problem

jw schultz jw at pegasys.ws
Mon Nov 11 20:31:00 EST 2002

On Mon, Nov 11, 2002 at 04:30:05PM +0100, uwp at dicke-aersche.de wrote:
> Mermgfurt !
> I have some problem with syncing two machines which are connected
> over a Gigabit-connection. I'm trying to use rsync with ssh because of
> the authorisation mechanisms (keys). It starts quite ok with 18 MB/s
> (this small speed may have something to do with our internal net)
> and falls down to 400 KB/s (!!!). This happens over a long period
> because those files I want to copy are very big (upto 70 GB per file).
> Even though I tried to increase the blocking size the speed just goes
> down and won't go up again. In fact it really writes 18 MB/s, it's not
> just a problem of -partial or something similar. Ok, I haven't tried
> it without ssh yet, but it really looks very strange.
> The version is the rsync 2.5.6cvs version from debian-unstable.
> Thanks for any help !

You haven't really provided enough data to even guess what
is limiting your performance.

You need look at CPU utilization, I/O load and network load
on both ends.  It isn't likely to be the network unless
there is contention, but CPU and/or I/O are probably the
problem.  I know in my case the reciever is CPU bound.
You could also be suffering from buss contention.

Is the 18MB/s actual data transfer (just what has changed)
during actual transfer?  If so you may be up against the
limitation of your disk+file systems.

My gut reaction is that 18MB/s is probably just short of the
best sustained throughput you can get out of your disk
subsystem as configured.  I'd suggest testing to see how
fast your receiver can handle sustained writes and how fast
your sender can read.  And burst rates don't count.  You
need sustained transfer rates.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at pegasys.ws

		Remember Cernan and Schmitt

More information about the rsync mailing list