Speed problem

Bruno Ferreira blueroom at mail.digitalmente.net
Mon Nov 11 16:10:00 EST 2002

At 16:30 11-11-2002 +0100, you wrote:
>Mermgfurt !
>I have some problem with syncing two machines which are connected
>over a Gigabit-connection. I'm trying to use rsync with ssh because of
>the authorisation mechanisms (keys). It starts quite ok with 18 MB/s
>(this small speed may have something to do with our internal net)
>and falls down to 400 KB/s (!!!). This happens over a long period
>because those files I want to copy are very big (upto 70 GB per file).
>Even though I tried to increase the blocking size the speed just goes
>down and won't go up again. In fact it really writes 18 MB/s, it's not
>just a problem of -partial or something similar. Ok, I haven't tried
>it without ssh yet, but it really looks very strange.
>The version is the rsync 2.5.6cvs version from debian-unstable.

         Look for the processor usage in the machines that are transfering 
the files. You'll probably see that one of those machines has about 100% 
processor usage, given that the big files are about 70Gb. Try massive block 
sizes, apart from that I have no ideas. The problem is unrelated from 
network bandwith, though...

         Bruno Ferreira

[This E-mail scanned for viruses by Declude Virus]

More information about the rsync mailing list