Long timeout on initial connection with time-out-option set

Reinder r.cuperus at student.utwente.nl
Thu Nov 7 13:15:01 EST 2002


Currently i'm trying to make a patch for the gentoo-emerge-system which 
uses rsync to update its portage-tree. It uses various rsync-server 
around the world using DNS-round-robin to distribute among them. Those 
servers should respond quite fast normally, but sometimes one server is 
down (or just drops connection-attemps from a client).

In such cases it takes rsync a very long time (>3minutes) to give up, 
and return an error. I tried to solve this issue by including the 
"--timeout=15"  option, but it appears that is only meant for 
connections that are already initialized.
Inspection with help from tcpdump shows that rsync retries after 3, 6, 
12, 24 and 48 seconds, with no respect to the timeout-value.

A max-retry-count-commandline-option would be helpfull in this 
situation. When i would be able to set for example --max-retry=2, people 
would only have to wait ~9 seconds before the next rsync-mirror is tried.

I hope this option could be included, if possible.

With regards,
Reinder Cuperus

More information about the rsync mailing list