Help please... rsync 2.5.5 on Solaris 2.7

Michael Fischer fischer-michael at
Mon May 13 20:20:02 EST 2002

    > -----Original Message-----
    > The error message says that the server shell couldn't find a command
    > named "rsync".  Check the bash startup scripts to make sure that they
    > run without error and that PATH is set correctly.  You said you
    > recompiled rsync.  Is the directory where you put the
    > executable (perhaps
    > /usr/local/bin) listed in PATH?
    > --Mike
    Hi Mike, the user "sun" exists on both hosts, from the prompt on both
    bash-2.03$ id
    uid=1061(sun) gid=50(sun)
    bash-2.03$ which rsync
    /usr/local/bin is in my System wide specified PATH. I get the same error
    even when I specify the full command, ie: /usr/local/bin/rsync...

You've got two machines involved, and I don't know which is which.
Your original log showed an attempt to pull files from machine sydney
to the local machine.  It's clear that rsync was found on the local
machine.  It tried to run the command "rsync --server ..." on sydney
using remsh.  The remote command failed because an executable file
"rsync" could not be found in the environment that is set up on sydney
by "remsh".  Try running some commands manually via remsh to see what
is going on on sydney, e.g.,
	remsh sydney which rsync
	remsh sydney whoami
	remsh sydney 'echo $path'
and so forth.


More information about the rsync mailing list